openSUSE Tumbleweed 更新 Linux 内核 4.16.1/2 和 kdeconnect-kde 1.3.0 等

openSUSE Tumbleweed 本周发布了 2 个快照(04160417)。主要更新了 Linux Kernel 4.16.1/2、kdeconnect-kde 1.3.0 和 GnuPG 2.2.6 等。

0416 快照更新了 Linux Kernel 4.16.1 和 4.16.2、adobe-sourceserifpro-fonts (1.014 -> 2.000)、dbus-1 (1.12.2 -> 1.12.6)、kdeconnect-kde (1.2.1 -> 1.3.0)、meld (3.18.0 -> 3.19.0)、sed (4.4 -> 4.5) 以及 YaST2 的几个模块。

dbus-1 和 dbus-1-x11 1.12.6 修复了 1.10.18 和 1.11.0 中引入的一些退化问题。

adobe-sourceserifpro-fonts 有很久没更新了。2.000 版本增加了 ExtraLight、Light 和 Black 几个字重,并将 Semibold 和 Bold 加重了一些。

Linux 内核 4.16.1 主要是更新了少量驱动。Linux Kernel 4.16.2 主要更新的是网络驱动和网络组件方面的修复。openSUSE Tumbleweed 在更新 Linux Kernel 4.16.2 的同时还修复了 swiotlb_alloc_coherent() 错误(swiotlb,参见 bsc#1088658 和 bsc#1088902) 和 v4l2-core 相关的问题(参见 bsc#1088640)。改进了 ip_tunnel、ipv6、ip6_gre、 ip6_tunnel 和 vti6 以更好的验证用户提供的隧道名称。

但是更新 0416 快照之后的系统内核显示是这样的,

kernel-default-4.16.0-1.6.x86_64
kernel-default-4.16.1-1.6.x86_64
kernel-default-devel-4.16.0-1.6.x86_64
kernel-devel-4.16.0-1.6.noarch
kernel-devel-4.16.2-1.5.noarch
kernel-macros-4.16.2-1.5.noarch
kernel-syms-4.16.0-1.5.x86_64
kernel-syms-4.16.0-1.6.x86_64

似乎是有些问题。 defaultdevel 以及 syms 不太搭。有人建议等问题解决之后再执行升级,或者在升级时先排除 kernel 以及与之相关的如 virtualbox 等,

zypper al kernel* virtualbox*

不过这一问题在 20180417 快照中得到了解决。

0417 快照更新了 gpg2 (2.2.5 -> 2.2.6)、iproute2 (4.15.0 -> 4.16)、nghttp2 (1.29.0 -> 1.31.1) 以及 sqlite3 (3.23.0 -> 3.23.1) 等等。

本周的更新有点少,而且还出了个 Linux 内核的构建故障。也许正是因为这个故障更新才少的。接下来应该有不少重大更新,KDE Frameworks 5.45.0 和 GNOME 3.28.1 已基本就绪。而包含众多改进的 KDE 应用 18.04 也已在望。©

本文发表于水景一页。永久链接:<http://cnzhx.net/blog/opensuse-tumbleweed-2018wk16/>。转载请保留此信息及相应链接。

雁过留声,人过留名

电子邮件地址不会被公开。 必填项已用*标注

特别提示:与当前文章主题无关的讨论相关但需要较多讨论求助信息请发布到水景一页讨论区的相应版块,谢谢您的理解与合作!请参考本站互助指南
您可以在评论中使用如下的 HTML 标记来辅助表达: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

This site uses Akismet to reduce spam. Learn how your comment data is processed.