openSUSE Tumbleweed 中的 Kernel 4.10.1 与 VirtualBox 5.1.16

上次提到过的 openSUSE Tumbleweed 升级内核导致 VirtualBox 无法启动虚拟机的问题,在 20170311 快照中又出现了。这次是因为升级的 VirtualBox 5.1.16 和 Linux 内核 4.10.1。好在有了上次的经验之后这次解决问题的时候轻车熟路了。

先检查了官方安装源中有上一版本的 VirtualBox 各组件:

virtualbox-5.1.14-3.3.x86_64.rpm
virtualbox-qt-5.1.14-3.3.x86_64.rpm
virtualbox-host-kmp-default-5.1.14_k4.10.1_2-3.3.x86_64.rpm

确认无误之后删除本地安装的新版本,

sudo rm virtualbox virtualbox-qt virtualbox-host-kmp-default

然后直接从官方源里通过指向文件的链接来安装上一版本的(因为有了新版本,旧版本就不显示在本地查询中了),

sudo rpm -i http://download.opensuse.org/tumbleweed/repo/oss/suse/x86_64/virtualbox-5.1.14-3.3.x86_64.rpm http://download.opensuse.org/tumbleweed/repo/oss/suse/x86_64/virtualbox-host-kmp-default-5.1.14_k4.10.1_2-3.3.x86_64.rpm http://download.opensuse.org/tumbleweed/repo/oss/suse/x86_64/virtualbox-qt-5.1.14-3.3.x86_64.rpm

最后运行安装 VirtualBox 服务的指令,

sudo rcvboxdrv setup

问题解决。看来又要好几天不能升级滚动更新的 openSUSE Tumbleweed 了。©

本文发表于水景一页。永久链接:<https://cnzhx.net/blog/kernel-4-10-1-and-virtualbox-5-1-16-in-opensuse-tumbleweed/>。转载请保留此信息及相应链接。

5 条关于 “openSUSE Tumbleweed 中的 Kernel 4.10.1 与 VirtualBox 5.1.16” 的评论

  1. 这个 Kernel 4.10.1让我的电脑无法启动到kde桌面了,但是高级选项的旧版内核就可以~看来滚动更新每滚一次都面临着巨大风险。。。

    • 的确是啊。也许你用了 NVIDIA 的驱动?Tumbleweed 对 NVIDIA 驱动支持没那么好。
      我之前也是经常遇到这个,后来干脆禁用了 N 卡。

  2. 引用通告: openSUSE Tumbleweed 更新 Linux 内核 4.10.3 和 KDE 应用 16.12.3 | 水景一页

  3. N卡驱动可以用我打包的。https://build.opensuse.org/package/show/home:nuklly/nvidia-driver

雁过留声,人过留名

电子邮件地址不会被公开。 必填项已用*标注

特别提示:与当前文章主题无关的讨论相关但需要较多讨论求助信息请发布到水景一页讨论区的相应版块,谢谢您的理解与合作!请参考本站互助指南
您可以在评论中使用如下的 HTML 标记来辅助表达: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>