更新 Entware 遇到错误

一直在使用的路由器是自己刷的 AdancedTomato。今天更新其中安装的 Entware 的时候遇到了错误:“optware opkg wget: /opt/lib/libssl.so.1.1: no version information available (required by wget)”。这个错误是在更新了两三个软件包之后出现的。想来是 Entware 更新的时候没有做好过渡。

然后就连 opkg update都无法成功了。采取了简单的处理之后终于可以继续剩下的更新/升级了。

系统中原来有 libssl.so.1.0.0,所以我就创建了一个软连接到这个已有的库文件上,

ln -s /opt/lib/libssl.so.1.0.0 /opt/lib/libssl.so.1.1

然后发现还有 libcrypto.so,也做类似处理,

ln -s /opt/lib/libcrypto.so.1.0.0 /opt/lib/libcrypto.so.1.1

接着继续更新,

opkg update
opkg upgrade

虽然会提示一个警告信息,说是 wget无法获取 libssl.so 和 libcrypto 的版本信息,但是可以顺利完成下载并安装更新。

©

本文发表于水景一页。永久链接:<http://cnzhx.net/blog/an-error-in-upgrading-entware/>。转载请保留此信息及相应链接。

2 条关于 “更新 Entware 遇到错误” 的评论

雁过留声,人过留名

电子邮件地址不会被公开。 必填项已用*标注

特别提示:与当前文章主题无关的讨论相关但需要较多讨论求助信息请发布到水景一页讨论区的相应版块,谢谢您的理解与合作!请参考本站互助指南
您可以在评论中使用如下的 HTML 标记来辅助表达: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据