openSUSE Tumbleweed 更新 Linux 内核 4.11.2、KDE 应用 17.04.1 以及 GNOME 3.24.2

openSUSE Tumbleweed 本周发布了 3 个快照(052105220524),更新了两个小版本的 Linux kernel 4.11.1 和 4.11.2,同时还更新了 KDE Applications 17.04.1 和 GNOME 3.24.2。

另外,视频驱动 Mesa 更新到了 17.1.0,浏览器 Mozilla Firefox 和 邮件客户端 Thunderbird 同步更新到 52.1.1,音频驱动 ALSA 更新到 1.1.4,办公套件 LibreOffice 更新到 5.3.3,而 BtrFS 文件系统快照工具 snapper 也升级到了 0.5.0。

Linux 内核 4.11.1 是一个非常小的更新,主要是针对 IPv4 和 IPv4 协议栈的改进和 ARM、ARM64 (AArch64)、x86 和 SPARC64 等硬件架构的修补,以及少量驱动更新。而 Linux kernel 4.11.2 主要是增加了针对三星 F2FS 文件系统的改进,还有针对 CIFS、EXT4 和 Ceph 等的少量修补,并加入了不少针对硬件架构的改进,提供了更好的蓝牙支持,以及大量驱动更新。

KDE Applications 17.04.1 修复了超过 20 个已知问题,还包括针对 Dolphin、gwenview、Kate、kdepim 和 kdenlive 等应用的改进。本次更新还将处于长期支持状态的 KDE 开发平台升级到了 4.14.32 版本。

在 KDE 应用 17.04.1 中存在一个已知的、会造成 KDE PIM (Kmail) 无法正常工作的问题。该问题已经修复,但是应该需要到 17.04.2 更新中才会提供给用户升级。所以请谨慎升级 snapshot 20170522。如果已经执行了升级,可以尝试按照 Wolfgang Bauer 的提示,通过 KDE:Applications 软件源安装 kdepim-runtime 来解决。

在 20170524 快照中更新的 Samba 4.6.3+git.25.0c154becb13 修复了一个存在于 Samba 中 7 年之久的一个高危漏洞 CVE-2017-7494。该漏洞允许在某些条件小通过共享文件区以系统管理员(root)权限远程执行任意代码。该漏洞可能造成的潜在影响与之前广为传播的 WannaCry 利用的 Windows 漏洞的程度相当。

其它一些较大的升级还包括 icu4j (55.1 -> 58.1)、krusader (2.5.0 -> 2.6.0)、xfce4-terminal (0.8.3 -> 0.8.5)、linux-glibc-devel (4.10 -> 4.11) 以及 perl (5.24.0 -> 5.24.1)。©

本文发表于水景一页。永久链接:<https://cnzhx.net/blog/opensuse-tumbleweed-2017wk21/>。转载请保留此信息及相应链接。

雁过留声,人过留名

电子邮件地址不会被公开。 必填项已用*标注

特别提示:与当前文章主题无关的讨论相关但需要较多讨论求助信息请发布到水景一页讨论区的相应版块,谢谢您的理解与合作!请参考本站互助指南