*

离线 cnhap

  • **
  • 54
关于升级php
« 于: 2019-06-21, 02:04:51 »
博主 只能来找你求救了,我已经折腾几次了,每次升级后  访问域名 都变成 Testing 123.. 的页面。
我把 今天最后一次操作的记录 复制出来了,你帮我看看 我是哪里操作的不对,造成升级后 网页变成 Testing 123..

https://cnhap.org/%E6%93%8D%E4%BD%9C%E8%AE%B0%E5%BD%95.txt
« 最后编辑时间: 2019-06-28, 00:03:17 作者 cnhap »

Re: 关于升级php
« 回复 #1 于: 2019-06-21, 08:20:47 »
我看你采取的是安装 PHP72 并且是多版本共存(yum  install php72)的模式(虽然你删除了 PHP 5 的版本)。我安装的是 PHP73 且是只有一个版本的 PHP 在系统中(yum  install php)(这里没有在安装的时候带上版本号)。

既然都要删除系统里的 PHP 54 了,为什么不直接安装单一版本模式呢?

我没有安装过多版本共存的模式。但是既然是多版本共存,肯定需要修改各种配置文件来指定要使用的 php 执行文件的路径。比如按照你的安装记录,你查询系统中 PHP 版本信息的话应该是这样(我猜测的),
程序代码: [选择]
php72 -v所以你最后那个查询指令没有返回正确结果。

搜了一下是有人介绍多版本共存的配置的,比如这个 https://cloud.tencent.com/developer/article/1068457
欢迎光临水景一页

问题解决后请「修改」原始帖子将其前缀改为「已解决」。

请阅读“论坛管理”里面的置顶内容,帮助维护论坛正常运行,方便你我他!

*

离线 cnhap

  • **
  • 54
Re: 关于升级php
« 回复 #2 于: 2019-06-21, 14:26:20 »
我之前 按你的教程 也试过,重启后 依然是  Testing 123 我也看过 配置文件 vhost.conf  没有变化。

Re: 关于升级php
« 回复 #3 于: 2019-06-21, 15:43:12 »
这里说的配置指的是系统执行环境的。因为照你上面的记录,php 的可执行文件不再是 php 而是 php72,所以对应的 php-fpm 的接口也变化了。

出现 Testing 123 说明 Apache 服务器没有问题。这是 Apache 安装后的默认页面/网站目录。存在的问题是,你的服务器没有将默认目录定位到你的网站的目录。所以还是服务器配置问题。你可以对比一下 /etc/httpd/ 跟之前的是不是一样。
欢迎光临水景一页

问题解决后请「修改」原始帖子将其前缀改为「已解决」。

请阅读“论坛管理”里面的置顶内容,帮助维护论坛正常运行,方便你我他!

*

离线 cnhap

  • **
  • 54
Re: 关于升级php
« 回复 #4 于: 2019-06-21, 20:17:26 »
博主的 意思是 我升级前 先把 /etc/httpd/ 目录 保存到本地,等升级后 在对比里面的文件 有什么区别 对吧?

Re: 关于升级php
« 回复 #5 于: 2019-06-21, 21:44:05 »
是的,我怀疑是有什么变化在里面。如果你是在尝试的话,我建议参考我的操作,这样我也更容易理解这里面的变化。我从来没有配置过多 PHP 或者其它共存的模式。

然后今天还看到另一个可能,就是启用了 SELinux 的话也可能会导致这个。但是这次升级应该不会导致 SELinux 突然就启用了。
欢迎光临水景一页

问题解决后请「修改」原始帖子将其前缀改为「已解决」。

请阅读“论坛管理”里面的置顶内容,帮助维护论坛正常运行,方便你我他!

*

离线 cnhap

  • **
  • 54
Re: 关于升级php
« 回复 #6 于: 2019-06-22, 13:01:32 »
是的,我怀疑是有什么变化在里面。如果你是在尝试的话,我建议参考我的操作,这样我也更容易理解这里面的变化。我从来没有配置过多 PHP 或者其它共存的模式。

然后今天还看到另一个可能,就是启用了 SELinux 的话也可能会导致这个。但是这次升级应该不会导致 SELinux 突然就启用了。

好的 我今晚回去 按照你的流程 来操作, 我需要把 所有 PHP 都移除不?

Re: 关于升级php
« 回复 #7 于: 2019-06-22, 16:06:59 »
按照我之前那个操作,是需要移除 PHP 的,不然安装没法进行。
欢迎光临水景一页

问题解决后请「修改」原始帖子将其前缀改为「已解决」。

请阅读“论坛管理”里面的置顶内容,帮助维护论坛正常运行,方便你我他!

*

离线 cnhap

  • **
  • 54
Re:
« 回复 #8 于: 2019-06-23, 00:20:51 »
感谢博主,虽然不明白怎么搞定了,但现在升级成功了,并网站可以访问,我就是想删除了所有的 php,楼主可以更新你的博文了^_^

最后用yum list installed | grep php 语句 查询出来的 发现 多了很多很多 php 相关的 ,比一开始的要多。
因我看了下 主机配置上vhost里 我没有配置phpMyAdmin 还不知道phpMyAdmin 能否正常打开,等有时间我在试试,今天终于不用回滚磁盘了。开心

https://cnhap.org/2019-6-23.txt
« 最后编辑时间: 2019-06-23, 00:24:37 作者 cnhap »

Re: 关于升级php
« 回复 #9 于: 2019-06-24, 21:59:28 »
很高兴你的问题终于解决了。我前两天看了一眼,后来因为忙就忘记回复了。

是不是最关键的还是要先删除所有 PHP 包(php-*)?
欢迎光临水景一页

问题解决后请「修改」原始帖子将其前缀改为「已解决」。

请阅读“论坛管理”里面的置顶内容,帮助维护论坛正常运行,方便你我他!